Testbed brand search engine down
Resolved·Full outage

Team identified and resolved the issue.

Tue, Sep 9, 2025, 05:24 PM
(1 week ago)
·
Affected components
Updates

Resolved

Team identified and resolved the issue.

Tue, Sep 9, 2025, 05:24 PM

Investigating

Testbed brand search engine is timing out and affecting redemption. Team is working to identify the issue and resolve.

Tue, Sep 9, 2025, 05:02 PM(22 minutes earlier)